Theta SC cannot upgrade

I have been granted with a Theta SC, but am having a few problems with it. The product was purchased in 2016 and was not updated. Current version is 1.01. The Theta has been kept in a closet and was used lightly on one occasion. There have been no drops or errors using the product. The product is able to charge no problem into a wall adapter, pc, and macbook. When I attempt to upgrade the firmware the PC and Macbook is unable to recognize the Theta instantly as if it isn’t even plugged in. I am unsure if I am using the original power cable or not, but I have heard that if the SC does not receive enough current it will be unable to connect to a machine. I have also attempted to plug the SC into multiple ports 2.0 and 3.0 and have ran it on 2 different machines, with several different micro USB cables. I am unsure what to do

Thank you

Did you leave the camera plugged in for several hours?

Does the camera icon appear on the Mac/PC?

1 Like

parliament, I apologise profusely if this is an insult to your intelligence but… did you actually turn the camera on before attempting the update? Yes, when you connect to the PC, the green light will come on because it will attempt to charge it, but you then have to press the (green-lit) power button again to turn the camera on.

First attempt… It took me a minute or so before I realised why the Theta desktop app couldn’t see the camera…doh! Epic fail from me…


Yes, I have left the camera in for several hours on both PC and Mac. I understand that sometimes if a device has a large amount on its drive it can take sometime for the machine to recognize it.

Yes, I have. Both on and off I have tried.

I honestly assume it is an issue with the current to the device or just faulty hardware. I have tried all methods from Ricoh support, methods searched on this forum, and thetas FAQ.

When the SC charges, can you use it to take a picture?

Press and hold the power button of the SC for 10 seconds and then restart it by pressing the power button again for 2 seconds.

Does the SC turn on to the point where you can get a Wi-Fi icon on it?

Its functionality works as intended, pictures videos, etc. Just connection to the PC does not work.

I have done that and have gotten the same results.

and yes.

Can you upgrade the firmware with the mobile app? This may not work from the SC.

I don’t have an SC to test.

There may be a bug in the desktop app which prevents the SC firmware from being updated. SC firmware 1.20 was last updated in 2017. If there’s a bug in the desktop app which prevents the SC from being recognized for firmware upgrade, we would likely not know about it.

It seems like you’ve tried everything.

The SC is not capable to grade via mobile, only SC2 and on.

The product might have to be sent in for repairs or scrapped.

Thank you