Theta SC Firmware Updates

firmware

#1

I cannot get the Ricoh Theta application on two different Windows 10 machines to recognize my (fully charged) Theta SC for a firmware upgrade from v1.0 to v1.2. I am using the USB cable that came with it and Windows Explorer clearly sees it. I keep getting an error message:
“An error has occurred
Sorry, please perform the operation again from the start.”
Help?


#2

Ed,

It sounds like you’ve tried all the right things. Everything else is working fine? Taking pictures, recharging…? How long have you had the SC? Have you tried using different USB cables? Using the one that came with it should, of course, but good, but it’s worth trying different ones.

Jesse


#3

Do you have the latest version of Adobe Air?

https://helpx.adobe.com/air/kb/determine-version-air-runtime.html

For the desktop app, I’m using app version 3.2.2

I’m using Adobe Air 27


#4

wait! ignore that post. I seem to recall that Ricoh switched to Electron and is not using Adobe Air anymore.

Make sure your desktop app is updated. You don’t have to update Electron (you don’t need it).


#5

Tried different cables. Both machines will ONLY detect the Theta with the included cable. I AM using version 3.2.2 of the app (just downloaded it). I’ve had this unit a little over a year-bought new from B&H…
I was hoping there was some button combo trick. This isn’t looking good…


#6

Ed,

It was working for a year before this? You did the firmware upgrade and it stop being recognized? I don’t know of a way to back down firmware upgrades.

This is so old that it’s probably completely useless. But linking just in case any of it would help:

http://theta360.guide/blog/camera/2016/01/20/fixing-bricked-theta.html

Have you tried official RICOH support?

https://theta360.com/en/support/contact/

Jesse


#7

Thanks to all who responded. I managed to get it to work on my home Win 10 machine. Still, the flaky behavior from ALL Win 10 machines I’ve come across regarding USB devices (Theta, iPhone) and card readers has been very frustrating.


#8

Oh, what finally worked? Was it Win 10 flaky behavior mostly? Agree that I’ve also had issues with Win 10 with several devices, not specific to THETAs.

I like a happy ending. :3theta_s:


#9

I forgot to mention that the first two machines were enterprise machines. So that MAY have been a factor. However, the flaky USB/card reader issue has been pretty “consistent” across all three machines. Most of the time I have to use an app for wireless transfers via a browser interface from my iPhone. My machines mostly refuse to detect it, despite intensive driver update research…