Main Virtual Tours SC2 Linux

Theta V won't stay on

Bought a used Theta V online. Charged all night. Turn it on, blue lights come on, then red light, 3 beeps and turns off. Then no light. If I disconnect usb cable and plug it back in, it goes through the same cycle. Any tips?

I bought a new Theta V and the same thing is happening to me. I have checked firmware is latest version (3.30.1) and tried to power-cycle the unit but it still keeps occurring… Any help would be greatly appreciated.

It looks like this is happening to me as well.

When you are charging the THETA V, does the LED on the power button go off? The charging could take up to 200 minutes (as indicated on the RICOH site).

https://support.theta360.com/en/manual/v/content/prepare/prepare_04.html

Hi,

Same problem here on different cameras Theta V (new camera).

When you try to charge the camera, the green light flash and you can let it for hours it won’t charge at all. As there is no battery, you can not update the firmware.
–> I’ve tried on different computers with the official cable (2 différents official cable)

I’ve had the unit plugged in for over 3 days, and it just keeps going through these cycles.

If it’s a new camera, suggest you contact RICOH customer support and consider a replacement.

The unit may be defective. Did the seller indicate that the unit was tested before they sold it to you?

Note that this is not an official RICOH forum. We don’t work for RICOH. This is just a bunch of people from the community. We could be wrong. However, from my personal experience, it seems like the camera is not charging.