THETA X - 1.10.1 firmware update keeps failing


I recently received my Theta X and I cannot update the firmware from 1.00.2 to 1.10.1. I have tried updating from the camera, iOS app and desktop Windows and macOS apps, but I always get the error message “Version update failed” on the camera screen after the transfer completes.

The battery level is 100%, no SD card inserted, and I have tried formatting the internal memory and resetting all camera settings.

Has anyone got any ideas? I haven’t had a reply from Ricoh support yet, and will have to return this unit if I can’t get it sorted soon!


Ricoh support recommended returning this unit, as they had not heard of this error before. There doesn’t seem to be an easy way to properly factory reset or manually flash a firmware file.

I’ve ordered a replacement so hopefully this one won’t have any issues!

1 Like

Thank you for reporting back on the outcome. I hope that the new camera works out better.

Best of luck!


Thanks Craig, the new camera works great and updated the firmware with no issues! I’ve been using your app to shoot in the 8K 2fps mode and the extracted frames look really good. I hope that Ricoh add the 8K options in a future update!


Hey, great news! @jcasman is working on another app right now that just does the 8K video settings.

For the current test app, the camera needs to be in “video” mode for the setting to be valid. We’re hoping to add some error handling to automatically set the camera into video mode when the 8K 2fps setting is sent to the camera in case it is in image mode. Currently, the command will fail with a non-helpful error message if the camera is in video mode.


Look forward to the new app! I haven’t had any issues with the current app, but I am in video mode 99% of the time.

1 Like