Theta X Firmware 2.10.1 - Unable to change the video settings

Having just updated to 2.10.1, I’m now unable to switch between the different video mode options. The camera was set to 8K/10FPS prior to the firmware update, which it still is afterwards, but I’m now unable to tap on that setting and switch to a different video mode.

Is it me, am I missing something?

Are you tapping on the LCD screen on the camera body? Did you turn your camera off and the back on?

Yes, tapping on the screen several times and rebooted several times. If I switch into photo mode I can switch between resolutions just fine tapping on the screen. Switch back to video mode, it’s just displaying the 8K/10. There is no oval dark background behind the text either which all the other function settings have.

on the body of the camera, there is a setting (LCD screen) to reset the camera.

If that doesn’t work, take the battery out of the camera to make sure it is completely off, then put the battery back in and turn it off.

Can you use the official mobile app to change the resolution?

Please try those and report back.

Also, do you have an Android mobile device? We have some software for testing that runs on Android.

Hello again,

I’ve tried both and now the camera is displaying 4K/30 (5 min) for frame rate instead of 8K/10.

I’ve attached a photo and you can see there is no black background oval behind the text for the resolution and frame rate setting. I can still change between 5.5 & 11K in the photo menu.

I realised I’d updated the firmware with the camera set to Developer Mode On. I’ve tried turning Developer Mode off and did a reset and remove battery, but still no difference.

I wish I hadn’t tried what you’d asked now because before at least it was stuck on the 8K/10FPS that I use. Now it’s stuck on something I’m unlikely to ever use! :frowning:

There is no black oval around the video fps and resolution on my THETA X.



There’s something different with your camera behavior and the camera I am using. You may want to try and contact RICOH official customer support. I do not work for RICOH.

This is a community of people with RICOH THETA cameras. As there may be a problem with your camera that cannot be replicated by the average person with a THETA X, you may want to contact RICOH for help.

You can of course keep posting here, but but we may not be able to solve the problem as we can’t replicate it.

Can you set the video fileFormat with the API?

If you wan’t to try out my demo app I made which can set the camera to 8k/10fps then here is the apk for android. You can download it in the google drive link or scan the QR code and follow instructions.

1 Like

Thanks Craig,

It’s me being dumb. I’ve not had the camera long, not used it much yet. It’s a quirk of the UI. I’d been playing around in the photos settings swapping between 5.5 & 11K and was expecting a similar interface for the video settings. I can swap video resolutions as per your photos. Thanks for taking the time to share with me.

It’s a shame that Ricoh haven’t added a few additional frame rates between 2 & 10 FPS. I use 4 and 7 quite a lot on my other camera.

The available framerates in the API are: 2, 5, 10.

The 5fps is not available in the UI on the camera.

If you need 5fps framerate, we can get @erikrod1 to publish his Android app.

The available framerates are here:

Hi Erik,

Many thanks for this,

I’ve downloaded and got it installed, just need to give it a try with the camera. I’m particularly interested in the 8K/5FPS addition you’ve added. Very useful for the type of GSV video mode work I do.