Theta Z1 raw video not getting stitched to Spherical Video

I’ve noticed that sometimes a Raw Video file does not get stitched to Spherical Video by the default Theta desktop App. When I drag the video to the application, instead of showing the conversion toolbox, the video automatically starts to play the unstitched Fisheye videos.

On investigating the difference between the videos which get converted and which do not - I noticed that the videos that fail to convert lack critical Meta Data Tags.

Some of the differences included -

  1. The faulty video lacked - Roll, Pitch, Compass and Accelerometer Data with Meta Tags not even appearing when using exiftools.
  2. Other tags such as GPS tags showed position with all zeros.
  3. Map Datum was shown as WPS-84 (instead of the usual WGS-84).
  4. There was also a ‘Warning’ Meta Tag which mentioned “[minor] Possibly incorrect maker notes offsets (fix by 666?)”. This tag was not present in the correct videos.

I tried to feed dummy meta tags to the video (taking the tags from a correct video) and tried to convert the video again - but still it wouldn’t convert.

Is this a known problem? Is there any other way of converting these videos. We will have to go back and capture the data again if we fail to convert these videos.

This problem occurs - once in a while (approx 1 to 2 videos in every 100 videos captured).

Thanks and regards,

I have not heard of this problem before.

Please confirm you are using the latest firmware.

Is there a reason that you are not stitching the video inside the camera?