USB API and Arduino for Camera Trap

Wake Camera From Sleep Works Using USB API

I just saw this working. Both wake from sleep and put camera to sleep works using the USB API.
Ignore the error messages on the console about “Could not open session!”. That is appearing because the camera is in sleep mode. I also saw a demo the USB API controlling live streaming in 4K

Wow this would be great! then i can just have the Pi+ Theta! Do you think it works for the Theta V, or is there something special about the Z1?
Ill try it out probably tomorrow!

meanwhile here’s our documentation for how to make camera traps out of both the Theta V (or really any camera you can boop with a servo) and the MADV

1 Like

It should work with the THETA V, but I only saw it working on the Z1.

argh, so testing this with the Theta V
i can turn PUT the camera into sleep mode

ptpcam --set-property=d80e --val=1

but i still cannot WAKE the camera up from sleep mode

ptpcam --set-property=d80e --val=0
it will even say it suceeded, but it is not true, the camera is still just off :frowning:

Note i can also power it down via

ptpcam -R 0x1013

BUT i cannot wake it up (which is what i want to be able to do)

Thanks for this test. I’ll try it with a THETA V. I only saw it wake from sleep with a THETA Z1.


I am currently working on a 360 TimeLapse project with a GoPro Fusion but I’ve had issues with the Wifi not being reliable for communication when camera gets over heated.
I’m thinking of trying out either the Theta V or the Theta Z1.

Have you had any success in waking up from sleep the Theta V via USB API?

Thank you!

I’ve seen it work with the THETA Z1. It definitely woke up from sleep with the USB API and went back to sleep. Note that I saw this demoed by a RICOH engineer with ptpcam. However, he assured me that there was nothing special with his setup.

I have not tried it with the THETA V.

To be honest, I was trying to get ptpcam running on Ubuntu 18.04 (my workstation) and I ran into problems. I plan to install it on a Raspberry Pi and test it again.

Maybe you can order a camera from someplace with a good return policy and try it out, then return the camera if it doesn’t operate as you intend.

I believe that @quitmeyer was not able to get the THETA V to wake from sleep.

Note that I personally have not tried it with either the THETA V or THETA Z1 because when I upgraded my Linux system to Ubutu 18.04, ptpcam stopped working for me and I didn’t dig into it to fix the problem. Also, I cleaned my office at some point in 2019 and put the Raspberry Pi in a box somewhere. I need to find the Raspberry Pi.

How long is the timelapse? Is it several days? Months?

Can you power the camera with an external power source? Or, is it powered by a battery?

For powered timelapse, the application below works.

Correct, I could not turn it on via USB api quickly.i could turn it on via an emulated keystroke sent to the USB, but then I could not control the camera.
I needed a speedy time sensitive turn on though.

Others have said that if you turn on a raspberry pi connected to it, it will wake up the camera at the same time. Never tried it myself, but that’s because it would be too slow

Thank you for the quick reply.

I am developing a solution to last a few months that’s why I don’t want to depend on the wifi connection. The tests I’ve made with the GoPro Fusion have led me to believe that when the camera gets too hot the WIFI communication doesn’t work properly. I’ve been able to get It to work properly for about 3 Days max.

I’m assuming that I can power and exchange data between (via USB API )a RPI 4 and the Theta 360 camera ?

I’ve used the gphoto2 before but not the ptpcam tool before. I guess there’s a lot to explore.
Thank you for the tlapser360 suggestion. I will dig into It.


Thank you for your response.

As soon as I get the Theta camera I will test if the waking up works with the Pi.


Absolutely can power camera and send USB API commands. Will work for months. See below.

Consider Power over Ethernet for the Raspberry Pi and then USB power to THETA with control from USB API.

gphoto2 works

But not the entire command set in my tests. You may get better results.

I know a developer that is going to release more code for the USB API for the THETA this month. Things may get easier. I haven’t used the code yet.


I use gphoto2 on a RaspberryPi with a theta V. All the commands are working ! The only issue is for the shutterspeed, libgphoto2 need a modification ( I found that the VendorID reported on the Theta V is 0x00000006, this number is MICROSOFT and not PENTAX (the ricoh shutterspeed is only for PENTAX VendorID) and a compilation. I post the solution in this forum



@Hugues This is great, thanks for including this information here, that looks like a useful modification for libgphoto. Looking forward to seeing your solution.

Thank you!

1 Like