App crashed while clicking on camera settings Z1

Hi all, I have an issue since today while using the Theta app.

I use a Samsung S8 plus. App already removed once and reinstalled on the phone. Plugin used previously without problems.

Can anyone help?

regards
René
Holland

Hi,
Can you provide more detail on the problem? Is the plug-in not coming up? You need to click on the “Camera settings” for the plug-in menu to appear. Is the mobile app crashing when you click on “Camera settings”?

List the following info:

  • camera firmware version
  • Android OS version

I’m running Android version 10 on Google Pixel 2.
My Z1 firmware is version 1.11.1

You can find the firmware and upgrade it with the desktop app on Mac or Windows.

One trick that may work is to delete your current camera settings. It’s best to back up your camera just in case.

This plug-in may be able to reset the settings of the Z1.

There’s a discussion about why the settings reset plug-in was built at the link below.


A separate technique to try is to put your phone in Airplane Mode to disable mobile data, then enable only Wi-Fi data, then connect to the Z1.

Thank for your quik reply Craig

Im using the latest firmware on the Z1 and Android version 9.0.

The mobile app is crashing when i click on camera settings.

Im not eable to reset the camera because im on vacation.

The trick with airplane mode doesnt work.

Best regards

René

Sorry to hear about your problems during your vacation.

Can you take pictures and use other commands with the mobile app and it’s only the plug-ins can cause it to crash?

I just tested my Google Pixel 2 to make sure that the RICOH THETA mobile app still works in general.

If it’s crashing only when you try and retrieve the plug-in information from the camera, but works otherwise, there may be configuration information that got corrupted. (I’m guessing). If that’s the case, deleting the plug-in configuration might work. (guess) Unfortunately, this would be a hassle as you just have a mobile phone would delete all the plug-ins and configuration settings.

If you have a friend that has an iPhone, you can check to see if the THETA iPhone app is crashing.

https://developers.theta360.com/en/docs/v2.1/api_reference/commands/camera.reset.html

@iantresman just posted a link to a mobile app that can send API commands.

Hope you manage to have a good vacation despite the technical frustration.

Thanks again Craig for your reply

I cant even enable one plugin, the crash happends when i try to click on camera settings . All other functions of the cam works normaly. I.dont have a friend with a IPhone. In had try it with a another Samsung S8 with the same android version but the crashed also.


the screenshot of the pic above show us an exclamation mark, does that mean something?

Thanks in advance

René

The exclamation mark is the compass. It is likely not related to your problem with the plug-in. You can get rid of that mark easily by recalibrating your compass by moving your camera in a figure 8. See below.

For the plug-in problem, you have the following options:

  1. As the camera is new, you should try and call the official RICOH support line: https://support.theta360.com/en/contact/
  2. There may be a related problem/solution in the official support database https://topics.theta360.com/uk/faq/c_00_z1/
  3. After your vacation, use the desktop application to delete the plug-ins from your THETA Z1
  4. If the above still doesn’t work, try and delete all camera configuration settings using the Settings Reset plug-in (I haven’t tested it with the Z1)

The only other thing I can think of is to manually run the plug-ins, assuming you have the plug-in you want to use already installed. Maybe manually running different plug-ins will change the configuration settings and allow the mobile app to connect.

image

Thank you for all your help Craig.
I cant wait to go home and the reset the camera and resolve the problem of this 1099 dollar cam.
Mabye the new ricoh theta hdr app from the makers of Avanto that i used for the first time this vacation mess up the camera.
We keep in touch

Many thanks

René

Hi Craig Im back in Holland

1/I have try contact the Support line but Holland has no support line i need to contact France .My frence is much worser rather my english.
2/I couldnt find a releated problem in the database
3/ i could delete the plugins but didnt solve the problem
4/The reset plug does not work with the Z1
5/ Best solution ask the dealer d.for a refund

Thank you