Can't connect to Z1 after 1.80.1 update


I can’t manage to connect to the Z1 camera after the camera was updated to the latest firmware. It tries to connect via wifi and immediately shows an error occurred (doesn’t state the error).

I need a fix for these. I tried to connect via Bluetooth and wasn’t successful.

Best regards,

Santiago Trujillo

Did you also update the mobile app on your phone?

RICOH THETA App Version Update Information | RICOH THETA

Hi Craig,

Yes I did. I got it to connect using the wifi directly and entering through device images. Still doesn’t connect via the app as it should but it’s a workaround for now. The issue seems to be with my phone a Huawei P30, because I’ve tried with other phones and it worked correctly.



I am having the same problem since I updated the firmware and mobile app to the latest version. Sometimes it connects to the wifi and then I can access the capture images, but as soon as I want enter the settings of the camera the wifi disconnects and the app crashes. I’m using a Samsung A41 and got the same crash on Samsung A70 of a friend.

I do not have the same phone and can’t replicate this.

I’m guessing, but you can try isolating the problem with:

  • turn off mobile data
  • turn off bluetooth
  • turn off battery saver

Tried all that already. It didn’t work. I’ll make a screen recording of the process I’m doing and post it if possible or at least a youtube link.

Thanks Craig

when you post it, can you also post:

  • firmware version used on Z1 - example 1.80.1 - if you can’t connect to the phone to check on the firmware version, use the desktop app. Download | RICOH THETA It’s called “Basic App” I’m assuming it’s 1.80.1 due to the title of the topic.
  • version of Android on your phone

Can you connect the Z1 to your PC or Mac using Wi-Fi? If so, open a web browser and type this into the address bar:

Your PC or Mac will need to be connected to the Z1.

It will look like this:

I confirm here with my p30 pro