Connecting RICOH THETA Z1 with Unity

In relation to the 2.4Ghz to 5Ghz:

I followed the mobile app guide, but I still can’t connect to the 5Ghz band.

I’m not sure if I’ve missed a step or if it’s something else.

In relation to the projection on the sphere:

For my application, as I only use the rotation of the user’s head (I don’t use the position), using a sphere doesn’t prove to be a problem.

The camera is exhibiting unexpected behavior. The expected behavior is to be able to connect at 5GHz with just the one setting change. Are you sure your router or mobile phone is set to 5GHz only or 5GHz preferred?

I’m not sure what the source of the problem is. You can try

reset wifi

RICOH THETA Z1 Wi-Fi Reset - #5 by craig

  • press WiFi and mode for 11 seconds
  • camera will reboot
  • after reboot, set to 5GHz again and try it with your mobile phone in AP mode as a test

reset all settings

Same as above, except use this API to reset all settings

theta-api-specs/theta-web-api-v2.1/commands/ at main · ricohapi/theta-api-specs · GitHub

other options

  • call official RICOH customer support Contact | RICOH THETA
  • The Z1 runs Android inside of it. Search for Android cannot connect at 5GHz on Google Search and try to isolate the problem.

I hope this message finds you well.

I wanted to provide an update regarding the 5Ghz implementation. Due to other pressing aspects demanding my attention, I had to postpone the implementation. However, I am now working on it.

Despite following all the steps mentioned by @craig, I haven’t been successful in getting it to work yet. My next course of action will be to attempt the setup with a different router. However, this might take some time.

Mean while, I’m also working in a more direct way to connect the Z1 to Unity, maybe I will focus in the VLC-Unity or some other unity plugin.


if you use your mobile phone to connect to the Z1 in Access Point (camera is hotspot) mode, does it connect at 5GHz?

Hi, I’m trying to apply the second method which involve the RTSP connection but I can’t seem to get it to work. My guess is that my URL is wrong. Do you see anything wrong with my URL?rtsp://THETAYN34119099.OSC:HuaxiaWang@
For user, I put the SSID of my Ricoh Theta Z1. For Password, I put the password I gave my Ricoh Theta Z1. Lastly, for camIP, I put the IP address of my Ricoh Theta Z1 which I found by using my IPhone’s settings app which allows you to see the IP address of a wi-fi network. I also never connected the Z1 via CL (Client Mode I think?) which I’m guessing is also where I could be going wrong as I don’t know how to connect to CL or what CL is? If you could explain if there’s anything you see wrong in my URL and how to connect the Z1 via CL as well as what CL stands for, it would be greatly appreciated.

Are you using the RTSP plugin, the HDR Wireless Live Streaming Plugin, or are you using a Linux computer to produce the RTSP stream.

To ingest on VLC and ffplay



ffplay -fflags nobuffer -i rtsp://<ip_address>:8554/live?resolution=1920x960

I’m using the RTSP plugin, will this work or do I have to use a different method?

I did the tests above with the RTSP plugin.

Instead of this:


Use this:


finding IP address

I’m running the dns-sd -G v4 THETAYN34119099.OSC.local command in my command terminal to find the IP address of my Ricoh Theta Z1 but it returns nothing. Is the format of my hostname wrong? Also what do I have to do with my Ricoh Theta Z1 so it’s detectable for the command?

I think I was able to find the IP address through connecting the camera to the Ricoh app on my phone but the camera feed still doesn’t connect to OBS. I have the Ricoh Theta Z1 set to client mode and started the RTSP streaming plug in mode on the camera. Then I started OBS and input the link on my media source in the following screenshot. Nothing shows up. Is there anything else I’m supposed to be doing to get it connect to OBS or is there anything you see wrong in my process?

Do you have the z1 in client mode? It is unlikely your router assigned an IP address if

Press the wifi button on the side until cl appears on the OLED

@Manuel_Couto See the section on configuration of your router to specific channels. The channel specification may be the same on V and Z1


5 GHz Access Point

If you have a 5GHz WiFi router, the THETA V may not connect to it reliably. You need to limit the channels to 36, 40, 44, or 48. The THETA V complies to the 5GHz standard W52(IEEE 802.11a/n/ac that works with channels 36/40/44/48.

Many 5 GHz routers comply to W58 standard, which allows dynamic channel allocation to include 149/153/157/161.

If your router is using those channels, the THETA V will not connect in client mode. Please refer to this Wikipedia article on WLAN channels.

Yes, I have my z1 in client mode. The following picture is of my camera in CL mode and running the RTSP plug in. Also are you saying that I need to use the IP address of my router and not my Ricoh Theta Z1 for the URL?

You have to use the IP address of the Z1. It is odd that it is (Z1 IP). Do you have access to the router? Can you log into the router and confirm the IP address? I suspect that the IP address is not When you confirmed the IP address with your phone using the mobile app, was the mobile app in client mode?

as a test, does this work?

Testing IP access with Insomnia. replace the serial number with the serial number of your camera. Replace the IP address with the IP address assigned to your camera.

testing RTSP plugin today (Feb 22, 2024)

Feb 23, 2024 Update Testing RTSP Stream with OBS

OBS configuration with RTSP stream from THETA Z1

Hi there!

Apologies for the delayed response, as I was down with a cold last week.

Were you able to get it working?

@Manuel_Couto did you see this post on the 5GHz channel? Connecting RICOH THETA Z1 with Unity - #32 by craig

I saw it, and I’m planning to try it out today.

I’m not sure if I’ll be able to post the results today or maybe just tomorrow, but I’ll get back to you as soon as I can.

Thanks for the help!

1 Like

Thank you, I successfully found the new IP address of my Ricoh Theta Z1 by setting my phone and the Z1 to client mode and was able to use this IP address to fix the URL for OBS. It streams successfully but with around 2 seconds of delay. Any advice on how to improve this delay?

  1. What would be your maximum acceptable latency?

  2. Did you use a low latency 5ghz WiFi router placed close to you? There can be significant differences also depending how far are your devices from the WiFi router. Both camera and PC with OBS…

We got less than 1 second latency between Hungary and Palo Alto. How far is the video being transmitted?