Sample images from Z1 Native/Dual--fisheye required please

Hi all,

I am experiencing an issue where the Ricoh Theta Stitcher just is not working with my Z1 images. Every time I try to stitch either a native RAW or DualFishEye HDR image, I get a ‘This image could not be processed 0x0000001’ error message. It’s frustrating as hell if I’m honest - I’ve tired it on multiple machines (intel/AMD, with gpu and no gpu, even a mac VM), checked lightroom/stitcher versions and reinstalled but no bueno.

I’m wondering whether this actually relates to the camera and possibly EXIF data? It would be extremely helpful if someone could send me a sample RAW unstitched image that you have personally tested with the Stitcher app. This way I can confirm whether it’s camera or machine related.

Any help with solving this issue as well would be greatly appreciated.

Thanks in advance :slight_smile:


1 Like

I found the answer in this community. If I remember right. It can only be a raw file and it has to be saved to the same folder as you’re pulling the file from. Not hundred percent sure. Just woke up.

Here you go. Welcome to the community! The Theta Z1 is a lot of fun. You feel professional even though you have no clue what you’re doing (that might be me though)

Good luck

1 Like

Thanks for the reply, yes I am doing all of the above. Are you able to send me a sample unstitched RAW image from your Z1 that you have previously stitched successfully please? This will enable me to test further

Wouldn’t it be more effective to provide a sample yourself so that we can check if anything with that is wrong?

Sure makes sense. Although I have carried out further testing today and the issue definitely relates to my camera. I downloaded 360rumours raw samples and I was able to stitch the images without an error message.

Here is a raw file from my camera;

I used the R0010340 from 360rumours samples;

OK, I can reproduce the error with your sample.

Overall, the DNG behaves well in Lightroom: It shows all the expected EXIF data, can be processed and exported as TIFF, etc. - so everything looks fine.

But during stitching it seems that the stitcher doesn’t accept the DNG as being created by the Z1.

From the manual:

Message displayed: The images could not be processed successfully: 0x00000001
Description/solution: The images that can be edited by this software are raw images output from RICOH THETA.

So perhaps, some meta data expected by the stitcher is missing or got corrupted.

How do you transfer the files from the Z1 to your computer?

Did it work before?

Is the camera brand new from the factory?

BTW: In PTGui, the DNG stitches without problems.

Perhaps the Ricoh stitcher looks for additional proprietary meta data.

Thanks for the help @CorLeone.

I transfer the files from the Z1 via the supplied USB cable.

Annoyingly this camera was purchased from eBay as a used item only a couple weeks ago though it was described as only used a few times (perhaps this is why)

Looking at the EXIF data, the missing data is GPS related, I can’t imagine this causing the issue?

Here’s a screenshot:
I used the exiftool cmd app to get this data.

Although, I did try copying the 360rumours sample EXIF data over to my camera’s image… lo and behold, the image can be processed ( however the stitch is not right, notice the bottom right hand corner. Distance settings don’t change the result unfortunately.

I have just tried PTGUI and I didn’t have much success, it stitched but not correctly (similar to the above) although that’s clearly because I’m doing something wrong considering you had it stitched seamlessly?

In addition I have just tried the Theta Z1 stitching app on Android and I was able to get a good stitch so I am tempted to stick with this, although not ideal considering the longer processing time.

Any thoughts?

Thanks again :slight_smile:

GPS data is added only when shooting via the app as the mobile device is providing the data.

Hmm, this is strange … Did you try to narrow down which EXIF tag actually made this possible?
From you comparison of the EXIF tags, I see nothing suspicious.

No, not without the flaws you also noticed in the result of the Ricoh stitcher.

Without any further input, PTGui uses some default for the lens correction and alignment parameters which may not suitable for your camera. In case you have no camera-specific template with the correct parameters, you can usually use automatic control point generation. But surprisingly, this fails for this image. PTGui seems to be confused by the image. Maybe this is caused by the reflections on the mirror and shiny surfaces.

Therefore, I added some control points manually. This eliminated the rough stitching errors but some flaws still remain (see the tiles over the bathtub):

Did you try a factory reset?

Does the in-camera JPEG show the same stitching errors?

I tried a factory reset using the API (I couldn’t find any easier way to do it?).

The JPEGs looked fine.

Hi Peter & all here, has the factory reset worked. I appear to be having an unusually similar issue.



Thanks for this update.
This is great information. How did you reset the camera?

Hi Criag! It was a question. I was wondering if the reset has worked, if so I would like to know as I believe i also have an issue with the photos (metadata/ exif) coming from the camera I purchased. Similar to above in this post I have tried the sample image which work fine with the stitcher. I can put them on G+ if you would like to look :grinning_face_with_smiling_eyes:

Can you post the image that does not work on Google Drive. Post the original DNG image from the Z1, not the one you got as a result of editing in Lightroom or equivalent.

The file name should be something like R0010952.DNG

Put the link here.

I have some sample DNG images here:

THETA Z1 Sample DNG RAW Images

This folder Contains the original photos taken by the camera. Those photos were imported to my hard drive, then uploaded.

The outdoor parking lot photo does open my Ricoh Stitcher without any issue.

I have not seen this before. Did you just buy the camera?

I am not sure if resetting the camera will have any benefit.

You can try this testing app to see if it makes a difference.


Result: Failure

File Export

Drag and Drop


Trying with darktable


Result: Failure

I purchased the camera off eBay.

It sounds like it is not even giving any clue as to why this might be happening, I will try the testing app :crossed_fingers:

Are you running the newest firmware on the Z1? I believe it is 2.00.1.

I have not seen the problem you have, so I am not sure what the source of the problem is.

There is no clue from the software.