Main Virtual Tours SC2 Linux

New Z1 and V Bluetooth Remote Control and Underwater Mode Free Upgrade

Even after rebooting Z1 and phone, very unstable wifi connection, only lasting for a few seconds.

Anyone else experiencing this after the upgrade?

Samsung Galaxy S7 (SM-G930F) with Android 8.0.0

Just saw the note in the instructions regarding slowing down the response speed of the wifi:

After turning off the remote control plugin, wifi connectivty gets better - but still not as before!
Preview runs for less than 30-60 sec before the wifi connection drops!

This makes the camera practically unusable!

Thanks. The color temperature icons are controlled by “CT Settings”. This should be made clearer for novice people. Maybe a link to a help window?

I’m not sure if the icons themselves are an improvement. I’ll try later with a V and look for the fish icon.

I’m using Google Pixel 2 with Android 10 security patch level Feb 5, 2020.

I’m using 5GHz wi-fi connection.

Did you remove the remote control plug-in from the list of selectable plug-ins?

Facebook post in Japanese

image

Shigeru Okada reported success with the device below.
image

Yoshihiro Satoh reports that the device below did not work.

This is the English version of the Japanese post on Facebook.

support for shooting with Bluetooth Remote Control (Theta Z1 / v / SC2)♪🎊

The firmware of Theta Z1 / Theta v has been updated, and the install plugin “Remote Control” has been added. This allows you to connect with the aftermarket bluetooth remote control to do remote shooting :exclamation:
Z1 / v is the settings using the plugin unlike the configuration procedure in the Theta SC2.
This will allow you to do remote shooting even if you don’t use your smartphone :smiling_face_with_three_hearts:
Please take advantage of it!

  • the following information will be published on the usage page of theta lab later.

How to set remote control in THETA Z1

  1. Update the firmware to the latest version
    Launch 2. Plugin “Remote Control” (Remote Control Mark Flashing)
    (method of booting the plugin)
    https://support.theta360.com/en/manual/z1/content/plugin/plugin_02.html
  2. Turn The Bluetooth Remote Control and paired with the theta (the remote control mark is lit)
  3. End the plugin
  4. Shooting from remote control
    ※ if you have a pairing once, you can unlock the sleep status of the theta by pressing the shutter button on the remote control.

How to set remote control for THETA V

  1. Update the firmware to the latest version
    Launch 2. Plugin “Remote Control” (Camera State Lamp in white flashing)
    (method of booting the plugin)
    https://support.theta360.com/en/manual/v/content/plugin/plugin_02.html
  2. Turn The Bluetooth Remote Control and paired with the theta (the camera state lamp is white lit)
  3. Shooting from remote control
    ※ if you have a pairing once, you can unlock the sleep status of the theta by pressing the shutter button on the remote control.

Remote Control settings for THETA SC2

  1. Hold on self timer button (Remote Control Mark Flashing)
  2. Turn The Bluetooth Remote Control and paired with the theta (the remote control mark is lit)
  3. Shooting from remote control
    ※ you need to pairing again after the power of the theta is turned off.

Yes, even after doing this the wifi connection is still very unrealiable.

How can I rollback to the previous firmware version?

I updated my Theta V and can confirm that I got my Bluetooth remote working. The underwater mode shows the fish icon, I can’t really tell the difference when switched on, I still have to play around with it some more.

2 Likes

Z1 owners, please participate in this poll to narrow down a potential issue with the new firmware 1.31.1.
Is the preview in the mobile app stable for at least one minute or does the connection drop before?

  • Have installed 1.31.1 and observe wifi instability now
  • Have installed 1.31.1 and don’t observe wifi instability now
  • Have not installed 1.31.1 yet

0 voters

(BTW: The wifi connection to my trusty old THETA S still works without problems.)

1 Like

I voted! Thanks for pulling this together @CorLeone, I’m interested in seeing the results.

@jcasman, are you experiencing instability?

The Z1 seems fine with my Pixel 2. I’ll put this poll out on a Facebook Group. Maybe we can get more responses.

1 Like

@LCalderon what remote are you using? If you have a moment, can you post the name and model?

I just received the unit below, but have not tested it yet.

I do not think there is a way to rollback the firmware.

It’s not a known brand. It actually came with a selfie stick that I use. I’ll post a picture when I get home.

1 Like

It would be great if you could also post the procedure that worked for you and your specific clicker. Such as:

  1. place clicker into pairing mode by long-pressing shutter button on clicker
  2. set THETA V into plug-in mode by long-pressing mode button
  3. something happens to LEDs on clicker and camera
  4. it works

Successful Test of JOBY Impulse Bluetooth Clicker

  1. started plug-in
  2. long-pressed JOBY Bluetooth clicker. It appears to have paired.
  3. Now working. Press bluetooth clicker and it takes the picture.
2 Likes

Sorry for the late reply.

  1. Started plug in
  2. Turned on Bluetooth remote (has an on/off switch)
  3. Pressed button and it takes the picture

2 Likes

New video from @YuqingGuo

image

image

1 Like

Did you resolve your problem? I was using my Z1 over the weekend with a Pixel 2. I had some problems until I disabled bluetooth on my phone. I’m not sure if the Z1 was trying to connect to my Pixel 2 with bluetooth or not.

1 Like

Just did some more testing: Indeed, disabling Bluetooth on the mobile seems to resolve the Wifi connectivity issue - great!
This is funny, as Bluetooth on the Z1 was disabled in both cases.
Seems to be a bug in the app. Will you report this to Ricoh?

1 Like

Thanks for reporting back on this. I still think there’s something sluggish about the camera-phone connection even after disabling bluetooth, but it seems usable in my case. I may try and do a factory reset on my Z1.

I can send this to RICOH, but want to confirm the specific device. You had this problem on this phone, right?

Samsung Galaxy S7 (SM-G930F) with Android 8.0.0

And the problem only started to occur after you tried to use the bluetooth remote control plug-in?

In my case, I used Google Pixel 2 with Android 10.

I only saw the problem after I tried the bluetooth remote and I still encountered the problem after I uninstalled the plug-in. I can use the camera now with bluetooth on my phone disabled and 5GHz Wi-fi. I have not tested the setup enough to have a firm understanding of the problem.

1 Like

Yes, my device is a Samsung Galaxy S7 (SM-G930F) with Android 8.0.0.

The problem started after upgrading to Z1 firmware version 1.31.1.

Of cource, I also tried the bluetooth remote control plug-in directly after installing the firmware, but I doubt that the plug-in itself causes the problem as I deinstalled it after unsuccessful testing.
Maybe deinstallation does not work currectly and a factory reset of the Z1 is required; haven’t tried this yet.

I would have rolled back to the previous firmware version if possible. Unfortunately it’s not.

1 Like

Thanks. That’s a good insight that it may not be related to the plug-in, but might be related to the firmware upgrade. Like you, I tried the remote control plug-in immediately after upgrading to 1.31.1. I’ve included your information in a report.