Problem installing the Windows desktop app for Ricoh Theta S

Hi, I’ve got a couple of Ricoh Theta S’s and have been happy snapping away taking 360 pictures and videos using the Android mobile app.

It seems there are firmware updates available for the cam. I have firmware 1.11.

However, the Theta S Windows desktop app which you can download from https://theta360.com/en/support/download/ doesn’t seem to install anything?

The download is called ‘SphericalViewer.exe’, it pops up with an install bar and then silently disappears. I tried ‘Run as Administrator’ and the same thing occurs. I can’t see anything being installed in Program Files or in the Windows Programs menu. This is on two different machines, one Windows 7 Pro and the other Windows 10 machines, both 64bit.

What am I doing wrong?

Andrew

PS. the Windows live streaming application (UVCBlender_setup64.exe) installs and detects the Theta fine.

Hi alfski
Be sure you have the latest Adobe Air Version 23.0
normally it installs together with the RICOH THETA app
You might have Adobe blocked in your firewall

https://get.adobe.com/air/
Regards Svendus

3 Likes

Awesome Svendus, yes needed Adobe Air. I feel like an idiot now!

I’m sure that information is in the install manual somewhere.
Ricoh should make it more obvious on the app download site!

2 Likes

Ricoh developers were on drugs when developing this, i can’t belive they don’t put it on their website, ot at least a frikkin warning from the installer!!

I agree it’s difficult to find. if you want the support notice for Adobe Air 24, here’s the link.

https://theta360.com/en/info/support/2016-12-19/

Was this problem with Adobe Air 24 ever resolved?

@codetricity
Hi iThink After the removal off Adobe Flash
Adobe Air are discontinued


check also this link
https://helpx.adobe.com/air/kb/archived-air-sdk-version.html
What to do next
Regards Svendus
1 Like

@Svendus Happy New Year, nice to hear from you!

Adobe Air no longer needed to install RICOH THETA desktop app. Full recommended operating environment (Windows and Mac) listed here:

https://support.theta360.com/en/enviroment/#PCAPP

@jcasman
Thank You :pray:
i Shall try later to day
we uninstalled the application yesterday to get into the troubles
one guy had on the Theta Facebook Group
:+1:

Sadly the bacic app
do not install here on Microsoft Windows
Version 1909 (OS-version 18363.1316)
We tried several times the installer gets stuck


it do not install on Windows
Version 1909 (OS-version 18363.1316)
installer
RICOH THETA Viewerfor Windows/Mac
Program
3.15.0.0
RICOH THETA
3.15.0
Ricoh Company. Lid. All rights reserved.
79.4 MB
2021-01-14 09:57
Enlish(USA)

2021-01-14_10-16-07 icopatible application

Desktop app no longer uses Adobe Air. Install of 3.15.0 went fine. My results below.

Test on January 13, 2021.

image

Install went fine.

image

image

1 Like

Same here, I’m running RICOH THETA desktop app 3.15 on Windows 10. No problems.

One difference could be the version of Windows 10.

svendus is using Version 1909 (OS-version 18363.1316)

I’m using 20H2, 19042.685, which is considerably newer.

What version of Windows 10 are you using?

I’ve running 10.0.19042 Build 19042

I reinstalled just now. No issues.

It could either be a problem related to the older version or a country-specific language issue that we can’t replicate with our US-versions of Windows 10.

@craig @jcasman
It was installed here but after uninstalling and reinstalling the problem occurred
when we tried help a guy on Facebook running into the same trouble (note: the application installs in an odd dictionary and not in the program folder (C:\Users\USERNAME\AppData\Local\Programs\RicohTheta)
1909 are the newest windows 10 here

got the latest https://en.wikipedia.org/wiki/Windows_10_version_history#Version_20H2_(October_2020_Update)

now installing


EDIT : installed same problem :cold_sweat:

Are there any characters in the “username” that are not in the limited ASCII (American Standard for Information Interchange) characters?

I wonder if the THETA desktop application is having a problem with the installation path?

The application is installed on my Windows 10 system in the location below:

"C:\Users\craig\AppData\Local\Programs\RicohTheta\RICOH THETA.exe"

One possible test is to create a temporary user account such as “sven” and see if you can install the application under that new user account.

2 Likes

the application installer are running but get stuck here we have canged the security settings in the whole dictionary for all programs to install but it is not the right place to install applications actually, can you please sent your theta folder in a zip file to me so i can try copy it to the machine here Note the application have no register posts so it should run (note i do not find it in my backups here :thinking:)

@craig @jcasman
I think we solved the problem with the installer

installed the older version Ricoh Theta version 3.3.0

when it was running we got this message

leading to this webpage https://support.theta360.com/en/download/pcmac/

after downloading and installing this happens

theta ok

RICOH THETA is running.
Click OK to close it.
after that the Ricoh Theta version 3.15.0
installed with no Problem

Conclusion: it seems that version Ricoh Theta version 3.3.0 has to be installed
and then upgraded to the latest Ricoh Theta version 3.15.0
hope this was helpful
Regards Svendus

1 Like

Note the application has no register entries
and installed it can run in any folder on a PC

1 Like