Ricoh 360 SC Dosen't Turn On - Green Light on when plugged computer - Nothing works

I bought a Theta 360 SC on Amazon in Oct/19.
Last week it just stop working.
Power button dosen’t work.
The green light is on when plugged into computer but it can’t recognize the camera. Nothing works…

Very disapointed with the camera. Very few uses…

@Bruno_Alvarenga Sorry to hear about the sudden problems. No fun. You used it before with no issues? Was there something different that happened before it stopped working? I’m not official RICOH support, but maybe I (or someone from the community here) can help.

You said it stopped working and the power button doesn’t work. Does that mean it does not start up? It does not boot up at all? No LED lights?

One possibility is that it has no charge. THETAs can be “picky” about what it will charge with. Ricoh recommends that you only use the one supplied with your camera. A poorly made cable could cause a voltage drop which will bring the charger delivered output voltage down below what is expectable for charging the camera. Have you tried plugging your THETA into a wall socket, not a computer? (Use a USB adaptor.)

If it appears like it really just stopped working and has some mechanical problem, official RICOH support may be your best choice:

If you’re in the US:

Outside of the US:

Hi Jesse.

I used it before ( few times). Charged it twice and all seens all to be normal.

When plugged with the cable ( computer or wall socket) the green lights turn on but the câmera still not respond to the power button. Tryed different cables (including the original) and the result is the same.

Nothing diferrent happens before stop working…

Made contact with the official RICOH support.

Hope they help…


@Bruno_Alvarenga As far as I can tell, you are doing all the right things. Please let me know what you hear back from RICOH support. If you’re willing to share, maybe we can help others.