RICOH THETA Movie Converter Mac just Crashes


#1

Hi,

New Theta owner here. I have tried on multiple machines running Sierra and it launches, crashes, and sends a crash report, every time. I had to use a Windoze machine to verify the Basic App converted them properly. The version is 1.0.

Any clue?


#2

Have you tried deleting the app and downloading a fresh copy from Ricoh? This happens with any processed clip from the Theta desktop app that you drag onto the application?


#3

Jonathan,

I’ve tried this with limited success, but the app is not crashing, so I’m including my experience in the hopes you have something to compare against, at least.

I’m using a MacBook Air running Mac OS 10.11.6 (El Capitan). Installation seems fine. I have a THETA V .mp4 video file (62MB) that I recorded at Thanksgiving that I can view in VLC. While the RICOH THETA Movie Converter seems to boot up okay, I get a message window that says I need to drag and drop the video file onto the icon. However, when I do, it’s not recognized. (The icon doesn’t change, and also I can’t go into the app and use the menus to get to Open file. It closes as soon as I click OK on the message window.)

Oh, wait. Actually, according to the instructions in the ReadMe.pdf file (see below) that come with the download, I’m supposed to do a conversion using the main desktop RICH THETA app first. However, it doesn’t recognize the THETA V movie file either. sigh

I notice in the instructions that their example is an .mp4 file. Mine’s a .m4v file. It’s the same thing, I think. So after trying to actually convert with VLC, I just manually change the file name. Lo and behold, I can import it into the RICOH THETA app.

This is where I’m stuck. I don’t see how to do Step 3 in the instructions: “Uncheck the [top/bottom correction] check box and click the [Start] button.” And then, according to the ReadMe, if that works, it’ll append an “_er” to the video name. And then you drag that onto the Movie Converter app.

So, not the same problem, but it’s not smooth for me either. I think I can get it, I just need to fool around with the RICOH THETA app a little more.

Jesse

The ReadMe.pdf that came with the download had the following instructions:

○ How to use RICOH THETA Movie Converter for Mac

Follow the procedure below to convert movie files with 360 o spatial audio into YouTube movie formats.

  1. Connect RICOH THETA V to your computer using a USB device and copy a movie file (for instance, R0010001.MP4) you want to convert to your computer.

  2. Start the main app for computer “RICOH THETA”, and drag and drop the movie file (for instance, R0010001.MP4) to it.

  3. Uncheck the [top/bottom correction] check box and click the [Start] button.

  4. Drag and drop the converted movie file (for instance, R0010001_er.MP4) to RICOH THETA Movie Converter inside the application folder.

When a dialog box appears, specify a file name and start conversion. After the file is converted, an MOV file (for instance, R0010001_er.mov) is output.

  1. After the MOV file is output, upload it to YouTube.

This procedure applies when the firmware ver.1.00.2 and the main app for computer “RICOH THETA” ver.3.1.0 are used.


#4

I have downloaded it several times and deleted, reinstalled several times. It crashes in the code signing module. I am guessing the certificate expired.


#5

I have the same problem.


#6

I’ve been thinking about this and remember reading something last year about applications on the Mac stop working because of the certificate expiring like this article: https://www.macrumors.com/2017/02/20/mac-apps-fail-launch-expired-apple-certificates/

I’m not sure exactly how you would renew a certificate if it is a certificate issue – perhaps look at your Keychain Access on your Mac and audit repair as necessary? There is an option to request a new certificate?

I am NOT recommending this course of action since I’m not that familiar. The best course of action is to contact Ricoh I would think.

Perhaps a screenshot of the error would be helpful.

I run it on a Mac with High Sierra and have no issues with the Movie Converter.


#7

How did you transfer your video file from the camera to the computer? My file is a .MP4. Did you use a Mac application to import it from your camera to the Mac?

I’m having problems with this:

  • macOS Sierra 10.12.5
  • Desktop App 3.2.1
  • RICOH THETA Movie Converter 1.0

I’m using the file ending in _er.MP4

I am dragging and dropping the _er.MP4 file onto the Movie Converter App. Is your icon light grey like mine is?


#8

I tried it on my El Capitan Hackintosh and it worked great.


#9

Thank you for your usage report. It’s helpful for the community. It seems like the Ricoh Movie Converter application works in general, but it doesn’t work on certain computers, including the one I tested on. I can borrow my wife’s MacBook and try another test.

Thanks.


#10

Crashes continuously on my Touch Bar MBP.


#11

Check out if you have the latest Version of ADOBE AIR

Installerad: 26.0.0.118 ?
Update: 27.0.0.124

http://www.adobe.com/products/air.html


#12

I got it running by self-signing the app. Not sure this can be seen as a recommended solution though so do the following very much at your own risk!

sudo codesign -f -s - /Applications/RICOH\ THETA\ Movie\ Converter.app/Contents/MacOS/RICOH\ THETA\ Movie\ Converter

#13

Thanks for posting the exact command


#14

Did it work for you on your own Macbook Air?

I haven’t tried it yet.

I saw that there’s a firmware and software upgrade for spatial audio. So, it’s likely that the Mac Movie Converter will be upgraded by the end of this month.