Support Information - Using RICOH THETA with MacOS X Sierra (10.12)

The following issues have been reported when using RICOH THETA for Mac in macOS Sierra(10.12) (released September 21).
・Will not start
Please avoid updating macOS Sierra(10.12) until the cause of these issues has been determined.

1 Like

Thanks for posting. I’m still in Yosemite (MacOS X 10.10.x) so I haven’t run into this.

Now running macOS Sierra 10.12 Virtually on VmWare fusion 8.5

And the RICOH THETA app do definitely not start on macOS Sierra 10.12
and you cannot install from all souses in Sierra
Tips: the best thing was to get the Application on App Store take it or leave it

Works for me.

1 Like

Great news we are running it virtualy on ElCapitain and do not know why it do not start, but in Case it does on a clean installation😉
it should be green light .

1 Like

It is Green light works here
upgraded to 10.12 this morning

1 Like

Has anyone been able to get download THETA for Mac desktop on macOS Sierra (10.12) ? I’ve tried several times today and was curious as to what kinds of success people have had. Thanks.

Hi downloading should be no problem
but installing :wink: you have to go to security settings and allow it to install
Regards Svendus

Hi upon reading the above is it only via Vm ware fusion that you are able to open theta program. (I’m on sierra 10.12.1) Thanks

Hi Kerry we tested first on a virtual installation and the RICOH THETA app did not start
on a clean install sierra 10.12.1 it is working but in sierra the option to be able to install everything
are removed so one has to allow it in the security settings
Adobe air should be installed at first
i think it is time to get the

Thank you, I have adobe air, but still just says “The application “RICOH THETA” can’t be opened” Im not sure which app as the australian app store only has the iPhone app in there, which I have on my phone. On my other laptop I can open and convert by downloading via usb which i would rather do than over wifi. I do have a FSP viewer o I can see images Ive downloaded but will not save them so I can upload to Facebook or you tube - thank you for your assistance

The RICOH THETA latest viewer version 2.3.0 for Mac and Windows are downloads from
Regards Svendus

1 Like

The Theta 360 app is not working for me either. I just did a fresh install of Sierra earlier today 10.12.1. There is a problem registering the camera and the basic app will install but it will not open.

Any suggestions?

Thank you

Hi Christopher
try to start the application in the Terminal
copy and paste this text in the openTerminal window

Applications/RICOH\\ THETA

Note: the should be in the application folder
see what error message you get and post it here

find the Terminal in Application/application-tools/Terminal

Regards Svendus

1 Like

That worked great. Thank you for the info. I’ll use this until they update the App.

Thank you once again!


1 Like

Actually I see that it opens with the app now. Even bigger thank you. :smile:


1 Like

great that it functions now

i think it is do to the new security settings in 10.12

this problem will be solved when the RICOH THETA app are on app-store

1 Like

Tried most every recommendation and nothing is working. (on Sierra 10.12 as well)
Issue: can download and install after updating Adobe Air, but the application won’t open, even with the Terminal workaround. This is what I get.
And doing a search for “ricoh” or “theta” on the app store doesn’t show the app, only other paid apps.
Hoping for a resolution soon.

Right click the Ricoh Theta app / show / content/MacOS/RICOH\ THETA drag the 64 bit application to the open Terminal window, the terminal will automatically write the path to the program, press enter post the error mesage from the terminal here
Regards Svendus