Ricoh theta V - wifi connection unavailable

Hi, i have a ricoh theta V, and it doesn’t reach to connect to the wifi. The light upon the wifi sign remain white, and the wifi light is lightening. Somebody knows what i can do?

can you take a picture of the wifi with your phone and post a small portion of it?

is it possible you have a plugin installed? Try connect it to a desktop computer with a USB cable and use the desktop app to delete unused plugins.

Is your firmware up to date? It’s possible that upgrading the firmware with the USB cable will reset the settings.

Is the WiFi LED on all the time? Or does it blink?


Ive already checked the firmware and the app. And it was good. I’ve opened again the online support and double checked the password settings. It was the password the problem, i’ve reset it, now it works!!
Many thanks for your advices, really appreciated!!!

1 Like

Thanks for the update. Great to hear you got the problem resolved.

Please mark the topic as closed/solved.


Done. Thanks for your help

1 Like