[Theta V][3.00.1][SOLVED] Self timer activates for video only

#1

When I turn on my Ricoh Theta V while pressing the wireless button the status LED is blue. In earlier firmware versions it would correctly glow green to indicate self-timer. I still can switch to video and get a green self-timer indication there, but not in photo mode.
Self-timer does not seem to be broken as I can still activate using a paired mobile phone - but it takes much longer to set up compared to the camera only self-timer activation.
Is there a way to restore self-timer activation for photo mode? Is this a firmware issue?

Idea for File Manager Plug-in
#2

I just used the self-timer yesterday with THETA V with firmware 3.00.1. (At least, I think I did).

Steps:

  1. camera is off
  2. press and hold Wi-Fi button on side of camera
  3. press and release power button on side of camera
  4. round LED above shutter button is now green
  5. took picture
#3

Exactly that’s how I remember it to work and how it should work. I just retried items 1.-3., and item
4. the LED above shutter button is blue (photo symbol is lit)
5. switch to video
6. the LED above shutter button is green (video symbol is lit)
When I try to record video the camera waits for 5 seconds before recording.

#4

try and hold the power button down for a long time. For example 18 seconds and then restart the camera.

Firmware 3.00.1

#5

I used to be able to do what codetricity described but It does’nt work any more. Now it does what Baloan said.
I tried resetting both the camera and the wifi.

#6

@james6161 thanks for this community usage report.

As I can’t replicate the problem, I suspect that it may be related to settings specific to the camera.

Last week @1116 suggested the community build a plug-in to reset all the settings:

I believe some people from the community are in the process of submitting this “reset plugin” to the store.

One question, what process did you use to “reset” the camera?


below is a screenshot of http://192.168.1.1/osc/info from my camera when my desktop is connected to the camera with Wi-Fi.

image

I recently tested the “reset” plug-in a few days ago, so all my settings are factory default.

#7

I held the power button for 18 seconds plus, then restarted. No change in behaviour.
The camera.reset seems worth a try, but I don’t have the nerves tonight to fire up my Surface, write the few lines of python to try it out. Isn’t there a built in way to factory reset the device?
I didn’t expect to write code to repair firmware issues when I bought the camera…

#8

Finally I got to install python with requests on my Microsoft Surface Pro, activate Wifi on the camera, connect the Surface to the camera, and check the connection:

> pip install requests
> python

Python 3.7.2 (tags/v3.7.2:9a3ffc0492, Dec 23 2018, 23:09:28) [MSC v.1916 64 bit (AMD64)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.

import requests
url = "http://192.168.1.1/osc/info"
r= requests.get(url)
print(r.status_code, r.headers)
print(r.json())

    200 

    {'Connection': 'Keep-Alive',
     'Content-Length': '38',
     'Content-Type': 'application/json; charset=utf-8',
     'X-Content-Type-Options': 'nosniff'}
     
    {'_bluetoothMacAddress': '00:26:73:D5:57:45',
     '_wlanMacAddress': '00:26:73:D5:B5:69',
     'api': ['/osc/info',
             '/osc/state',
             '/osc/checkForUpdates',
             '/osc/commands/execute',
             '/osc/commands/status'],
     'apiLevel': [2],
     'endpoints': {'httpPort': 80, 'httpUpdatesPort': 80},
     'firmwareVersion': '3.00.1',
     'gps': False,
     'gyro': True,
     'manufacturer': 'RICOH',
     'model': 'RICOH THETA V',
     'serialNumber': '00117652',
     'supportUrl': 'https://theta360.com/en/support/',
     'uptime': 497}
1 Like
#9

And reset the camera:

>>> url = "http://192.168.1.1/osc/commands/execute"
>>> payload = { "name": "camera.reset"}
>>> r = requests.post(url, json = payload)
>>> print(r.status_code)
>>> print(r.json())
200 
{'name': 'camera.reset', 'state': 'done'}

The camera did its red and blue LED blinking activity. After that, camera photo self-timer activation works again. Turning on the camera with the Wifi button pressed results in a green LED for photo mode.
Thanks, @codetricity for the hint.

2 Likes
Plug-in for THETA V Settings Reset - Now in Store
#10

@baloan Thanks for the update. Appreciate the success report.

This new plug-in by Vitaliy, Leaning len, and John P may help others that aren’t as comfortable with scripting as you are.

https://pluginstore.theta360.com/plugins/guide.theta360.settingsreset/

#11

Update:
Ok, not only did I have the above problem but… Although I could connect my camera to the app, everytime I tried to change camera settings the app crashed. This has been going on for weeks now.
Thanks to Codetricity great Reset plugin everything is working back as normal.
Sorry Ricoh for giving you a hard time.

1 Like
#12

wow, great to hear.

Just to give credit to the appropriate people:

  • idea by @1116 Vitaliy
  • development by Leaning Len
  • Submission and finishing by John P

I’m just the facilitator helping people to get requirements and assisting with submission to the store.

#13

This is really cool to hear that the plug-in solved the problem. As @codetricity suggests, there may be other ways to handle it, but it’s great that it worked for you. :3theta_s:

1 Like
#14

Yea, I was surprised that resetting the camera settings to factory default actually worked for a number of people. The question that I have is how could the settings become corrupted? It seems possible that something may occur with the official mobile app and result in unusual cases where the camera is missing settings.

For example, it’s potentially possible for the camera to drop the network connection during the middle of an API call, which could result in a setting being “null”.

It’s a mystery as to why the problem is occurring, but in some cases, this plug-in appears to help. It’s definitely cool that the plug-in can function as a little utility to do one thing to fix one problem.