THETA SC2 crashes Google Street View app


I recently got a Theta SC2.

The theta app works perfect, but when I try to use the SC2 in the Google Street view app, the Theta SC2 crashes.
When I open the street view app, it connects to my SC2, but when I try to take a picture, I get no preview of the image on my phone and all the buttons on the SC2 stop responding.

Finally I have to hold the power-button on the SC2 for 10 seconds to reboot the SC2.

Anyone else got this problem?
Any known workaround?

Kind regards,

1 Like

Please post the following:

  • phone model - whether it is Android or iOS, and model such as Google Pixel
  • OS version - example - Android 10
  • SC2 firmware version

Should be 1.20 for SC firmware

Streetview version

Hi Craig,

Tested on a Samsung S10e - Android 10
The SC2 is updated to 1.2 and the streetview app is version
The last update on the streetview app appears to be in November 2019, which is older than the SC2.

I will try to install the streetview app on an other phone, to see if this makes a differance.


Thanks. I will try and do a test today with Pixel 2, Android 10.

I have confirmed some differences between the SC2 and the V/Z1 during tests with the mobile SDK and with my own test scripts. I have not tried the SC2 with Google Streetview.

Let’s both report back our tests.

I will share this discussion with my contacts at RICOH. The more information we have on testing, the better.

I did the same test on a motorola G7 Andoid 8.1.
Same result.

Crash of the SC2


@dvp Thanks for your help. I may not be able to test until this afternoon or tomorrow. I am including your test information in a report I am sending to RICOH.

I tested Google Streetview on a Moto-G 3rd Gen running Android 6. Note that I was not able to get Streetview to see my Google Pixel 2 running Android 10.

SC2 Test Process




SC2 locks, becomes unresponsive and I need to hard power off.

It’s stuck at this screen when I take a picture.

The SC2 then becomes unresponsive to physical button presses.

V Test

Works fine.

Yup, same problem here. Is it the SC2 or SV app?

I have the same problem. Nexus 6p, Theta SC2.

I just upgraded to SC2 firmware 1.31 (newest one from 4 days ago) and I am having the same problem. Unfortunately, the firmware upgrade didn’t fix the problems with Google Streetview.

If the camera locks, press and hold the power button for longer than 12 seconds (roughly). This will force a power down.

The V and SC2 have slightly different APIs.

I used a Pixel 2 in my test.

Exactly Same problem here,

SC2 with Google Street view
I have Moto G7

From just a learner here, can I please ask if this SC2 + Google Street View incompatibility is an unfortunate consequence of a design compromise (eg. reduced capability of SC2 API), or simply due to delay in other parties (eg. Street View, Matterport) incorporating the new API, but in time, all will be fine? Or maybe is fine on some other Android or IOS platforms?
Thank you.

1 Like

Same problem. Samsung S9 with Android 10, Theta SC2 version 1.31, Street View version

1 Like

Hello there,
Got today my Theta SC2 and I have the same issue.

Theta firmware updated to version 1.42
StreetView updated to versione

My phone:
Xiaomi Redmi 9
Android 10
the phone has everything updated too

I had the same problem with mine using my Sony Xperia XA2 and Firmware 1.42

But updating to Firmware 1.51 seems to have fixed the issue!

Update after playing around with it a little bit more, I can take and import still image using the street view app, but not video files.

When attempting to take an “interval” (with the video icon) I get the error “Unable to capture image, please try again.”

If I take a video using the theta app, I can import it into the street view app as a “new video”, but I get the error “failed to process video”, when attempting to download the video from the Theta device.

I can download the video file to my phone, but I can’t see a way of importing the file from the phone to the street view app, so currently I don’t think this works for videos

Hi, guys. Happy New Year 2021.

Unfortunately, Streetview app is dead due to revamp of SV Trusted Program.
Have read the following article?

Hope this helps.