Main Virtual Tours SC2 Linux

Live Streaming over USB on Ubuntu and Linux, NVIDIA Jetson

Update by moderator: July 29, 2020

Open source patch for libuvc now available to get streaming from THETA V/Z1 to Linux, including NVIDIA Jetson and x86 https://theta360.guide/special/linuxstreaming/


original note by community member:

I am trying to live stream from my Theta V in Ubuntu, over USB using OBS. OBS can stream the built-in camera just fine, but it doesn’t see the Theta.

  • lusb sees the Ricoh Theta.
  • ptpcam -c is able to initiate a capture.
  • ptpcam -g is able to download the captured photo.
  • modinfo uvcvideo shows I’ve got UVC 1.1.1 on Linux 4.4.0.
  • lsusb -vd 05ca:1712|grep UVC shows the camera supports UVC 1.5. (05ca:1712 was the camera ID obtained from lsusb).
  • v4l2-ctl --list-devices does not see the Theta.

From discussions on this forum and elsewhere it is clear that UVC 1.5 is not available on Linux, and that is the issue I’m facing. Some of the posts on this forum are stale and that’s why I’m asking here again.

I see on this forum that one brave soul wrote a UVC 1.5 driver for Android but the source code is not available. But anyhow that is Android, and still wouldn’t help us with Linux.

So I just wonder if there are workarounds or how others are tackling this issue?

Other posts indicate that I should be able to stream MJPEG over UVC 1.1, but OBS doesn’t even see the device. Has someone got MJPEG to work?

Section 14.2 of the FAQ seems to indicate the Raspberry Pi CAN stream from a Theta connected via USB but then seems to contradict it later. So I’m very confused on whether that is possible. Anyone know?

I think the THETA S can stream in MotionJPEG over the USB cable, but the THETA V cannot. The FAQ refers to a THETA S at the beginning part. It needs to be updated.

Slightly late reply here, but I wonder if you could use the HDMI output and then an HDMI-USB converter? That might get around the UVC 1.5 problem… Anyone think that might work?

@ReedsHorton - Sorry, I don’t understand. How do I get an HDMI output from the Theta V?

He’s likely referring to a THETA S, which has an HDMI output port.

Yes I think I switched them in my mind, not quite sure what I was thinking then. There was also a Theta camera with HDMI output at the time marketed more towards streaming 24 hour video with a metallic case, can’t remember the model name though.

RICOH R

Any new updates on this post?

I saw a demo of usermode Linux driver streaming from a THETA V several months ago. However, the developer got busy with other things and has not released the driver yet.

As of April 16, 2020, I do not know of a streaming driver for Linux.

Any new updates regarding getting live stream from Theta V or Z1 in Ubuntu ?

I’ll check with the developer again. Hopefully, he’ll put it out this month or next month.

1 Like

I tried to get live streaming over USB from Theta Z1 in Ubuntu (16.04.6 LTS). However there was a segmentation fault error while running your sample code from https://github.com/ricohapi/libuvc-theta-sample . Do you have any suggestion on how to fix this? segmentation_falut

I just tested it today, July 29, 2020. It worked on my system without mods to the c code or example. I’m going to make a short video on the build and dependency process for the patched libuvc. I will try and post this video today. There was a long list of dependencies that I needed to install to build libuvc properly.

Go to this link https://theta360.guide/special/linuxstreaming/

Put your email in and you will see this page with a new video. It shows the full download from GitHub, compile, run, along with the dependencies. Please post again if you have problems.

I’m trying to use libuvc for RICOH THETA, which is just released.


I’ve updated the firmware for THETA V to the latest one(3.40.1).
I successfully built the library and the sample program on both two Ubuntu 18.04.4 LTS environments: Jetson TX2 and a Generic PC.
However, sample programs dont work with the error “uvc_open: Not supported (-12)” on both environments.
Is there anyone who faces the same issue?

i get the gstreamer-app-1.0 ,and try by https://github.com/ricohapi/libuvc-theta-sample.git;
when uvc_open ,it gets -12(device not support). but my device is theta thetaV and it is on live model

i get the gstreamer-app-1.0 ,and try by https://github.com/ricohapi/libuvc-theta-sample.git;

how to get gstreamer-app-1.0 on ubuntu? i can not find it.

I believe it is in libgstreamer-plugins-base1.0-dev

https://packages.ubuntu.com/xenial/amd64/libgstreamer-plugins-base1.0-dev/filelist

See the video that is now on this info page of this site.

https://theta360.guide/special/linuxstreaming/ (put your email in and you will see a different page)

Please review the section on libuvc compilation with the appropriate dependencies and patch in the video.

update July 29, 11:30am PDT: I added a small troubleshooting section under the video, including a screen shot of remote git branch usage and package location of gstreamer-app-1.0